Back to overview
Maintenance
Security upgrade on panel.
Apr 2, 2026 at 3:25pm UTC
–
Apr 2, 2026 at 3:45pm UTC
Affected services
SwissRDP Homepage
Resolved
Apr 2, 2026 at 3:25pm UTC
Security update.
Affected services
Resolved
Apr 2, 2026 at 3:25pm UTC
Security update.
Affected services