Back to overview
Maintenance

Performance update.

Jun 2, 2026 at 2:25pm UTC  –  Jun 2, 2026 at 4:25pm UTC
Affected services
SwissRDP Homepage

Resolved
Jun 2, 2026 at 4:25pm UTC

Maintenance ended

Created
Jun 2, 2026 at 2:25pm UTC

Performance update.